Problem updating the Discover menu

Incident Report for PelfoxNite Public

Resolved

This incident has been resolved.
Posted Jun 08, 2025 - 10:34 CEST

Investigating

We are currently investigating this issue.
Posted Jun 08, 2025 - 10:06 CEST
This incident affected: PelfoxNite (Website).