Slowdowns on websites

Incident Report for PelfoxNite Public

Resolved

This incident has been resolved.
Posted Mar 09, 2025 - 13:32 CET

Identified

You may experience slowdowns on the PelfoxNite website and status site.
We are working to resolve this issue.
Posted Mar 05, 2025 - 18:44 CET
This incident affected: PelfoxNite (Website, Status website).