Website slowdowns and inability to edit

Incident Report for PelfoxNite Public

Resolved

This incident has been resolved.
Posted Mar 11, 2025 - 21:13 CET

Investigating

We are experiencing an issue with our website that is preventing us from making changes, which will delay the release of articles for the Fortnite update.
You may also experience some slowdowns on the site.
We are actively working on it.
Posted Mar 11, 2025 - 18:29 CET
This incident affected: PelfoxNite (Website).